Jump to content


Photo

Cannot record https profile


  • Please log in to reply
8 replies to this topic

#1 daggerdanny

daggerdanny

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 17 October 2016 - 03:53 PM

I am trying to record a profile for a url - https://loadtest.website.org.uk/.  I can access this site with no issues from the WAPT server.  As soon as I start recording though I get a proxy error message.

 

The proxy server isn’t responding
  • Check your proxy settings 127.0.0.1:9471.
    Go to Tools > Internet Options > Connections. If you are on a LAN, click “LAN settings”.
  • Make sure your firewall settings aren’t blocking your web access.
  • Ask your system administrator for help.

 

If I select another https URL on a different website, it works.  What could be different with this website?

 

If I use Chrome as the browser, it says connection reset.

 

Very frustrating as the only site I need to test doesnt work within WAPT at the moment.

 

I have also tried to use firefox but I get a WAPT Firefox add on problem.

 



#2 Sergei Leonov

Sergei Leonov

    Advanced Member

  • Administrators
  • PipPipPip
  • 662 posts

Posted 18 October 2016 - 04:24 AM

What versions of WAPT and browser do you use?

I tried and successfully recorded the site on the latest version of WAPT.


Sergei Leonov
WAPT Project Manager
SoftLogica LLC

Office: +7-383-335-6692
Toll-free: 1-888-364-6797 (for US only)
Time zone GMT +6, EST +11
E-mail: support@loadtestingtool.com
http://www.loadtestingtool.com

#3 daggerdanny

daggerdanny

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 18 October 2016 - 08:34 AM

What versions of WAPT and browser do you use?

I tried and successfully recorded the site on the latest version of WAPT.

 

The URL above isnt the actual site.  I messaged it to you privately.

 

However, I am using WAPT 3.5 and it didnt matter which browser, they all failed (IE 11, FF latest and Chrome latest).

 

Thanks!



#4 Sergei Leonov

Sergei Leonov

    Advanced Member

  • Administrators
  • PipPipPip
  • 662 posts

Posted 18 October 2016 - 01:04 PM

Thank you for the information. Now I see the problem.

We will fix it shortly.


Sergei Leonov
WAPT Project Manager
SoftLogica LLC

Office: +7-383-335-6692
Toll-free: 1-888-364-6797 (for US only)
Time zone GMT +6, EST +11
E-mail: support@loadtestingtool.com
http://www.loadtestingtool.com

#5 daggerdanny

daggerdanny

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 18 October 2016 - 06:37 PM

Is that a fix as in a new version of WAPT?



#6 Sergei Leonov

Sergei Leonov

    Advanced Member

  • Administrators
  • PipPipPip
  • 662 posts

Posted 19 October 2016 - 03:48 AM

Your site requires TLS. It is supported in the latest version of WAPT.


Sergei Leonov
WAPT Project Manager
SoftLogica LLC

Office: +7-383-335-6692
Toll-free: 1-888-364-6797 (for US only)
Time zone GMT +6, EST +11
E-mail: support@loadtestingtool.com
http://www.loadtestingtool.com

#7 waptnewbie

waptnewbie

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 29 March 2017 - 02:51 PM

Hi,

 

We are experiencing somewhat similar problem. We are trying to performance test a site, that is not live (DNS lookup would not return any IP address), thus we have added the IP address and its domain to the 'hosts' file (on the server running WAPT).

 

Accessing the site from the computer across different browsers works fine. Accessing the site from within WAPT fails with the message as described above. The SSL certificate requires TLS 1.2. Could that be the issue? Or is the issue, that we have added DNS entry in the 'hosts' file.

 

We have WAPT 8.5 running on Windows 10 enterprise. We are using the following browsers:

 

Microsoft Edge 38.14393.0.0
Chrome Version 57.0.2987.110
Firefox 49.0.1

 

Regards WAPTnewbie



#8 Sergei Leonov

Sergei Leonov

    Advanced Member

  • Administrators
  • PipPipPip
  • 662 posts

Posted 29 March 2017 - 04:00 PM

Try to use the latest version of WAPT.


Sergei Leonov
WAPT Project Manager
SoftLogica LLC

Office: +7-383-335-6692
Toll-free: 1-888-364-6797 (for US only)
Time zone GMT +6, EST +11
E-mail: support@loadtestingtool.com
http://www.loadtestingtool.com

#9 waptnewbie

waptnewbie

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 30 March 2017 - 12:12 PM

We’ve just updated to the newest version (9.3), and got passed the above issue. However, now we can’t replay (or verify the reply). A network error is displayed.

 

Network error: 10000 - ""

 

We have tried to add the certificate on the client side, but without any success. Wireshark reveals that the SSL handshake fails. The only topic I could find on this issue is:

 

https://www.loadtest...et-error-10000/

 

Where the solution was to upgrade to a newer WAPT version. Since the topic is dated back more than 5 years ago, I believe the solution is not working for us.

I find this completely baffling, that the tool can record a session but not reply it.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users