Jump to content
WAPT Forum
Sign in to follow this  
vinx1127

Memory Issue on Small Virtual Users

Recommended Posts

Hi,

 

I tried running a ramp-up load from 0-250 users with Steps 20 for every 3mins which will run for 1hr and 30mins.

 

My test had stopped at 1:17-1:26 mark due to fully utilized memory on 2 Load Agents ( 6GB and 4GB).

 

Now, I'm trying to figure out what could be the possible reasons behind this.

 

I'm tossing between these factors

 

  • I'm running a profile which contains 210 page requests and consist of several logins/logouts on it (I know this is not a good practice but let it be there first)

 

  • Before running my profile I noticed the Physical Memory on my 2 load agents
  1. 6GB - 80% Physical Memory already consumed by other processes. 20% left
  2. 4GB - 30% Physical Memory already consumed.

Now, i just want make sure that my profile will not cause this memory issue.

 

Is there a difference between having a single profile with many page requests vs partitioning the page requests with different profile in terms of memory utilization of the load agent.

 

 

Thanks,

Marvin

 

Share this post


Link to post
Share on other sites

What version of WAPT do you use? Could you give me your profile?

 

Memory utilization depends on the number of requests in the scenario, no matter in single profile or multiple profiles.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×