Jump to content
WAPT Forum
Sign in to follow this  
niekell

JavaScript Disabled During Test

Recommended Posts

Hello,

 

Why does WAPT record with one setting for "Active Scripting" and yet run with it turned off when inside a "Loop"?

 

Here are my steps:

 

1) I recorded all my Profiles successfully via the IE integrated browser of WAPT Pro 2.5 with JavaScript ON.

 

2) I ran "Verify Test" without any "Loop" objects and it was 100% successful. WAPT reported everything was okay, and the database behind the test also showed all the data was being manipulated correctly.

 

3) I ran a "Verify Test" WITH a "Loop" around a group of pages in which data was being set then reset so as not to clash on the next iteration of the "Loop", BUT it always runs with JavaScript turned off!

 

I have an ASP.NET AutoPostBack in the "Loop" and that is failing because it requires JS to be on.

Why is JS off when inside a "Loop" but on outside it? That doesn't make any sense to me!

 

Can someone please investigate it and fix it?

 

Best wishes, Paul.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×