Jump to content


Only some users in CSV file work


  • Please log in to reply
2 replies to this topic

#1 Guest_trashy_*

Guest_trashy_*
  • Guests

Posted 08 November 2011 - 04:12 PM

I'm loading my test users from a CSV file. However, when I run my script using these users, the page requests for every other user return a 404 error.

Taking the below CSV file contents as an example, user1@xyz.co.uk, user3@xyz.co.uk and user5@xyz.co.uk are ok, but user2@xyz.co.uk, user4@xyz.co.uk and user6@xyz.co.uk return a 404 error.

"user1@xyz.co.uk","123qwe"
"user2@xyz.co.uk","123qwe"
"user3@zyz.co.uk","123qwe"
"user4@xyz.co.uk","123qwe"
"user5@xyz.co.uk","123qwe"
"user6@zyz.co.uk","123qwe"

All users login to the web site fine when done via a browser. If I mix the users around in the CSV file, it will always be the users on the 2nd, 4th and 6th lines in the CSV that will fail.

It appears that the request headers are incorrect for the users that are failing.

Example of successful request header:

GET /order/start.aspx HTTP/1.1
Cookie: ASP.NET_SessionId=wybminluqezp21mxgrqfj0ln; SessionToken=8D447FC5-ECCB-440E-AE4B-52D14E733001; EvolviToken=8D447FC5-ECCB-440E-AE4B-52D14E733001; BIGipServerERSVPWMWEB-8010=3360201226.18975.0000; BNES_ASP.NET_SessionId=eDlayLNIRk+TwVNeMb7LV2Q1B+6bmB3GghxuIY41ebhVH5RIfvfsd5VZOffBnespWOl+Gnfh7UkJmUBaIu2DB9gDA8oBhAvHAxquz6L3cBo=; BNES_SessionToken=OXlxQjC2NQC4ibiGfK53vaVK+Y37Eo3H4IMHJr5DwMnrO3B8nmpJZR2TojI/KCPYghpCyCCWq+e1y3fBBLcAhPyu8d3RXNS2/3Tw5gpmHzrZwQ4vHQ41pQ==; BNES_EvolviToken=TEw0RYhj/Zu7oM7UYBju9uquwTCXjHRrI0IqXmNQPzRMsVU0ZuwL2EyMZiCBkC/xRBcOWuFy0tTupTMspFVtGhqO+MSMNvq868zZ+smQBjMyIieKzU/SSg==; BNES_BIGipServerERSVPWMWEB-8010=8yIjuTD+ZSaDoiIwszk3BkPLyJt6iQVGnBGeCN31yYqV4DGygQl5YLGP1BoTFMw4Qyn1hMEbqzqFlkKNpv+EafCk4lVOvL0aQIUnLAwY1UTmrY3fbUAH4A==
Accept-Language: en-gb
Accept-Encoding: gzip, deflate
Cache-Control: no-cache
Accept: image/gif, image/jpeg, image/pjpeg, image/pjpeg, application/x-shockwave-flash, */*
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0)
Host: railooto.evolvi.co.uk

Example of failing request header:

GET / HTTP/1.1
Cookie: ASP.NET_SessionId=djwxno55qie43b45x0xcax45
Accept-Language: en-gb
Accept-Encoding: gzip, deflate
Cache-Control: no-cache
Accept: image/gif, image/jpeg, image/pjpeg, image/pjpeg, application/x-shockwave-flash, */*
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0)
Host: railooto.evolvi.co.uk


Does anyone have any idea what I could have done wrong?

Best regards,

Paul

#2 Sergei Leonov

Sergei Leonov

    Advanced Member

  • Administrators
  • PipPipPip
  • 662 posts

Posted 09 November 2011 - 06:56 AM

We need the profile (.wpr file), scenario (.wps file) and full logs of successful and failed users. Please, send them to support.
Sergei Leonov
WAPT Project Manager
SoftLogica LLC

Office: +7-383-335-6692
Toll-free: 1-888-364-6797 (for US only)
Time zone GMT +6, EST +11
E-mail: support@loadtestingtool.com
http://www.loadtestingtool.com

#3 Guest_trashy_*

Guest_trashy_*
  • Guests

Posted 09 November 2011 - 07:55 AM

We need the profile (.wpr file), scenario (.wps file) and full logs of successful and failed users. Please, send them to support.


Thanks, but it turned out that one of the load agents had gone bad, hence every other user was failing.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users