Jump to content
WAPT Forum
Sign in to follow this  
Guest JMusters

Our Site uses Active Directory

Recommended Posts

Guest JMusters

Our sites use active directory to authentic users. When recording the session we are prompted to provide a username and password that we do not get when just browsing to it. What is the suggested method to over come this.

 

thanks

 

Jonathon

Share this post


Link to post
Share on other sites
Guest JMusters

Is there a way to tie other username/passwords to the recorded actions so that I can setup multi users with credential from the NTML username password prompt.

 

thanks

 

 

It is a normal behavior for NTLM authentication recording. Just enter credentials and continue recording.

Share this post


Link to post
Share on other sites

Yes, you can setup different users on Profile properties page. Check Authentication checkbox and enter usernames and passwords.

Share this post


Link to post
Share on other sites
Guest HUman

Greetings!

 

I have a problem with Active Directory authentication. When page request is send the window for my username and password shows. Than I enter them login works OK I get to the site but when i verify the test scenario I get error 403 authorization failed. I have checked the box for authentication enter username and password but still the same error.

Wapt doesnt record my password and user name so there is no username and password fields on URL parameters view. Also the Log file of the web page writes error on if you try to enter username and pass parameters. Without AD it works ok.

Is there any solution for this problem?

 

for better understanding here is a screen shot of authentication end error which is shown on verify.

 

authentication:

post-10280-0-78042100-1337604650.jpg

 

URL parameters view:

post-10280-0-04055200-1337604656.jpg

 

Verify report:

post-10280-0-94832100-1337604731.jpg

Share this post


Link to post
Share on other sites

Greetings!

 

I have a problem with Active Directory authentication. When page request is send the window for my username and password shows. Than I enter them login works OK I get to the site but when i verify the test scenario I get error 403 authorization failed. I have checked the box for authentication enter username and password but still the same error.

Wapt doesnt record my password and user name so there is no username and password fields on URL parameters view. Also the Log file of the web page writes error on if you try to enter username and pass parameters. Without AD it works ok.

Is there any solution for this problem?

 

for better understanding here is a screen shot of authentication end error which is shown on verify.

 

 

 

Could you give me your profile and verification log or send them to support?

Share this post


Link to post
Share on other sites
Guest HUman

I forgot to mention that our site uses single sign on with IIS for automatic authentication.

So you first access the IIS than when the authentication is done you are transferred from IIS to our website.

 

I can send you my profile but it wont be of any use because the site you try to access is on my local PC.

 

 

So if you insist I can send you my profile.

Share this post


Link to post
Share on other sites

I forgot to mention that our site uses single sign on with IIS for automatic authentication.

So you first access the IIS than when the authentication is done you are transferred from IIS to our website.

 

I can send you my profile but it wont be of any use because the site you try to access is on my local PC.

 

 

So if you insist I can send you my profile.

 

It's Ok. Send me your profile and verification log. I'll try to understand your issue.

Share this post


Link to post
Share on other sites
Guest Paulo

Hi Sergei

 

I'm testing WAPT 7.5 and I have the same problem reported here.

 

The verfiy test stop on page 4 with "401 Authorization Required" message.

 

Can you help me to solve this issue.

 

Thanks

 

Paulo Palma

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×