Jump to content
WAPT Forum
Guest Mark

Running from Command Line

Recommended Posts

Guest Mark

Probably a stupid not so technical question .... but I tried following the instructions to run this tool from the command line and am failing badly.

 

My command:

-run Login.wps [-noexit] [-hr Results] [-sr Results] [-csv Results] [-log Results]

Response:

"-run" is not recognized as an internal or external command, operable program or batch file.

 

 

Or else...

 

My command

WAPT.exe -run Login.wps [-noexit] [-hr Results] [-sr Results] [-csv Results] [-log Results]

Response:

Program opens with no wps selected and nothing else happens.

 

 

Any help would be appreciated.

 

 

Share this post


Link to post
Share on other sites
Guest angela
Probably a stupid not so technical question .... but I tried following the instructions to run this tool from the command line and am failing badly.

 

My command:

-run Login.wps [-noexit] [-hr Results] [-sr Results] [-csv Results] [-log Results]

Response:

"-run" is not recognized as an internal or external command, operable program or batch file.

 

 

Or else...

 

My command

WAPT.exe -run Login.wps [-noexit] [-hr Results] [-sr Results] [-csv Results] [-log Results]

Response:

Program opens with no wps selected and nothing else happens.

 

 

Any help would be appreciated.

 

Hi,

 

You should remove [] square brackets. Also, you should specify the full path to your scenario file.

In general, you should always specify full paths to all files and folders.

 

Share this post


Link to post
Share on other sites
Guest pon
Hi,

 

You should remove [] square brackets. Also, you should specify the full path to your scenario file.

In general, you should always specify full paths to all files and folders.

 

I am having the same problem, this is what I'm entering into the command line:

 

 

C:\PROGRA~1\SOFTLO~1\WAPT\WAPT.exe -run C:\Documents and Settings\user\My Documents\MyWAPT\Location8am.wps -noexit -hr C:\Documents and Settings\user\My Documents\MyWAPT\HTMLReports -log C:\Documents and Settings\user\My Documents\MyWAPT\logs

 

all it does is open up WAPT...

 

am I not using the -run command correctly? :(

Share this post


Link to post
Share on other sites
Guest pon

I am having the same problem:

 

C:\PROGRA~1\SOFTLO~1\WAPT\WAPT.exe -run C:\Documents and Settings\user\My Documents\MyWAPT\Location8am.wps -noexit -hr C:\Documents and Settings\user\My Documents\MyWAPT\HTMLReports -log C:\Documents and Settings\user\My Documents\MyWAPT\logs

 

all it does is open up WAPT.

Share this post


Link to post
Share on other sites
Guest angela
I am having the same problem:

 

C:\PROGRA~1\SOFTLO~1\WAPT\WAPT.exe -run C:\Documents and Settings\user\My Documents\MyWAPT\Location8am.wps -noexit -hr C:\Documents and Settings\user\My Documents\MyWAPT\HTMLReports -log C:\Documents and Settings\user\My Documents\MyWAPT\logs

 

all it does is open up WAPT.

 

You need to put all files names and paths in quotes, this should fix the problem.

Share this post


Link to post
Share on other sites

Hi!

I just upgraded to WAPT Pro 5.0 from WAPT 7.5.  I can attest that running WAPT Pro with the command line using the -run option just opens WAPT and doesn't load the scenario/profile.  When I run with the -noui option, nothing appears to happen. The test I'm trying to run ramps up to 500 users with 1 user being added every 5 seconds.  I have to be unwittingly omitting something.  Any help out there?

WAPT Pro > WAPT Pro 5.0 (64-bit) Built on Oct  6 2019
WAPT Pro > Load settings from file: C:\ProgramData\Softlogica\WAPT\settings.xml
WAPT Pro > Loading profile from file: C:\StressTesting\Tab3.wppx.
WAPT Pro > Load profile OK: C:\StressTesting\Tab3.wppx.
WAPT Pro > Load scenario OK: C:\StressTesting\Tab3.wpsx.
WAPT Pro > Load agent ****2 is online.
WAPT Pro > Load agent localhost is online.
WAPT Pro > Load agent localhost running users 0
WAPT Pro > Load agent ****2 running users 0
WAPT Pro > Test started.
WAPT Pro > Load agent localhost running users 0
WAPT Pro > Load agent ****2 running users 0
WAPT Pro > Test finished.

Share this post


Link to post
Share on other sites

Please, update your WAPT Pro to the latest build. If it will not resolve your issue, please give me your scenario and profile.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...