Jump to content
WAPT Forum
Sign in to follow this  
Guest denig

Can't Load Java.

Recommended Posts

At present WAPT recorder doesn't support recording for Java applets. You can try to record profile in your browser.

 

1. Run WAPT 7.0.

2. Start recorder (click the Rec button).

3. Determine WAPT process ID (PID) in the Task Manager.

4. Execute the "netstat -a -o" command in command prompt to determine the listening port used by WAPT (marked with its PID).

5. Set HTTP proxy in your browser as localhost:.

6. Now you can record all actions in the browser.

 

Share this post


Link to post
Share on other sites
Guest Ujjwal

At present WAPT recorder doesn't support recording for Java applets. You can try to record profile in your browser.

 

1. Run WAPT 7.0.

2. Start recorder (click the Rec button).

3. Determine WAPT process ID (PID) in the Task Manager.

4. Execute the "netstat -a -o" command in command prompt to determine the listening port used by WAPT (marked with its PID).

5. Set HTTP proxy in your browser as localhost:<port number>.

6. Now you can record all actions in the browser.

 

 

At step#3: which process name I need to look for PID as I can't find anything related to wapt at services tab in the Task Manager.

At step#5: can you little bit elaborate from where I can put the port number? and also let me know that can we record actions in browser using wapt tool, if yes then how?

Share this post


Link to post
Share on other sites
Guest Ujjwal

At step#3: which process name I need to look for PID as I can't find anything related to wapt at services tab in the Task Manager.

At step#5: can you little bit elaborate from where I can put the port number? and also let me know that can we record actions in browser using wapt tool, if yes then how?

Share this post


Link to post
Share on other sites
Guest Ujjwal

In the latest version of WAPT you can just select an external browser for recording.

 

Thanks for replying.. :)

Please let me know how could I be able to verify and run test for the recorded scenario from external browser.

Share this post


Link to post
Share on other sites
Guest Ujjwal

You can verify and run test as usual.

 

I have an scenario like: I have an applet having thumbnail image, thumbnail gets enlarged on clicking on it and I need to record this scenario, can you help me!!!

 

I have already tried by adding a scenario using the url of web service was been called, but is does not show its response time [response time shown blanked] after executing it.

[As you already know that the url remains same for each navigation link and I need to record the scenario of the next page and hence I created its scenario]

Share this post


Link to post
Share on other sites

I have an scenario like: I have an applet having thumbnail image, thumbnail gets enlarged on clicking on it and I need to record this scenario, can you help me!!!

 

I have already tried by adding a scenario using the url of web service was been called, but is does not show its response time [response time shown blanked] after executing it.

[As you already know that the url remains same for each navigation link and I need to record the scenario of the next page and hence I created its scenario]

 

I think there was some error during the test. Check the report and test logs.

You can send your WAPT logs and Results (*.wpr file) to support. We will try to help you.

Share this post


Link to post
Share on other sites
Guest Ujjwal

I think there was some error during the test. Check the report and test logs.

You can send your WAPT logs and Results (*.wpr file) to support. We will try to help you.

 

That is the main thing that I can not record a profile.

Pre-condition:

1. Go to second page like click on any applet having a thumbnail.

2. Click on thumbnail of an image.

 

Scenario:

1. Followed the pre-condition

--> I am on second page [and the url is same as for first page].

2. Now I wanted to record that page using external browser.

[when I started recording, it asked to reopen browser and restoring the browser session, the browser is opening the first page as the url is same.. ;)]

 

 

Could you please suggest what I am doing wrong!!!

Share this post


Link to post
Share on other sites

That is the main thing that I can not record a profile.

Pre-condition:

1. Go to second page like click on any applet having a thumbnail.

2. Click on thumbnail of an image.

 

Please clarify, do you record precondition steps or not? To create a correct scenario you need to record all your actions in browser.

 

Scenario:

1. Followed the pre-condition

--> I am on second page [and the url is same as for first page].

2. Now I wanted to record that page using external browser.

[when I started recording, it asked to reopen browser and restoring the browser session, the browser is opening the first page as the url is same.. ;)]

 

 

Could you please suggest what I am doing wrong!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×