Jump to content
WAPT Forum
Sign in to follow this  
Guest Sreenadh OG

Problem with Wapt Pro 2.0 Beta

Recommended Posts

Guest Sreenadh OG

Hi,

We have a site developed using .Net and Ajax (uses Yahoo UI Library, Ext, Magic Ajax etc). Since our company had already purchased WAPT 6.0, I was experimenting with the same to record and performance test this site. But I ran into many issues with WAPT 6.0, such as -

1) It was not recording AJAX xml responses that happened within Javscript model windows (using Ext Ajax). Due to this, for example, using the $Search function was not returning the required XML for me at all.

2) There was no facility in WAPT 6.0 to write debug logs/messages.

3) There was no way I could extend (write own functions/logic/programs) WAPT 6.0. I was thinking possibly writing custom test pages and passing variables from with in WAPT to those pages and receiving those variables back to WAPT after some process for scenarios where WAPT recording was failing may solve the problem. But since the "search parameter" function itself was failing to find the required data, I realized that even this will not solve my problem. If I am unable to even capture the required data, how can I pass it to another page for further processing/validation? I was searching for an alternative, a solution. And wola! I found WAPT Pro 2.0 Beta!

First of all thanks to you guys to developing such a wonderful program. And I know that it is still in its Beta and possibly that is why I am running into some problems with it. First let me spell-out the advantages I found for WAPT Pro 2.0 Beta in our scenario -

1) It did record the xml post as well as the xml responses. (Smoothly like firefox firebug, I feel like saying) :)

2) Now I can write debug logs/messages with a Javascript function

3) The application is extensible/programmable using Javascript (and I can write my custom functions and use it)

4) (Even though not mentioned in any documentation) I think, now can even pass WAPT variables to custom pages (written for testing logic inclusion purpose) and get back the responses and use it from within WAPT. [This will make WAPT truly extensible and useful, making us capable to implement almost anything with it]

On 25th March morning I downloaded WAPT Pro 2.0 Beta and suddenly came to know that this version will certainly solve my problems; everything was working fine as expected; I verified above listed 1,2,3 possibilities and was thinking of testing 4 soon. I was happy. And that is why appreciate you guys for making such a wonderful program.

 

Problem:

----------

But today morning when I try to record scenarios with WAPT Pro 2.0 Beta, suddenly it won't load page elements, it won't record post back xml, it won't record all the sub page calls!!! Everything was going wrong; WAPT Pro 2.0 Beta started behaving abnormally in my machine. (Windows XP/IE 7). Yesterday it was working fine in the very same machine! What happened today - I wonder! I tried almost everything to solve the problem. I uninstalled and reinstalled the application multiple times. Uninstalled, removed all the registry entries of WAPT Pro and then re-installed it. All in vain, nothing worked. It is still not recording sessions properly in my machine. I know that this tool works, I know that it is the tool I want (and after evaluation, with in a few days most possibly we will buy it), but I wonder why this problem? Why does it behave in this way today, while yesterday it was recording correctly?

Can you guys please look into this issue and help me please?

Regards,

Sreenadh

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Possibly, there is some problem with a setting up of a recorder proxy. We will add some error handling and give you a new build.

Share this post


Link to post
Share on other sites
Guest Sreenadh OG

Dear Sergei,

You could be right. Actually -

1) WAPT Pro 2.0 Beta works correctly while I am in office ('Automatically detect settings' configured in IE)

2) WAPT Pro 2.0 Beta behaves erratically and do not record properly while I am at home ('Automatically detect settings' configured in IE)

Even though there is no settings difference as far as IE is concerned, there could be some internal proxy setting differences which I am not aware of.

Thanks for the help. I will download the new build, try and will provide the feedback.

Thanks Regards,

Sreenadh

 

Possibly, there is some problem with a setting up of a recorder proxy. We will add some error handling and give you a new build.

 

Share this post


Link to post
Share on other sites
Guest Sreenadh OG

Dear Sergei,

Thanks for the fix. I will download, try and will provide you the feedback. Thanks for the great tool, as well as the quick support and reply.

By the way -

//Even though not mentioned in any documentation I think, now can even pass WAPT variables to custom pages (written for testing logic inclusion purpose) and get back the responses and use it from within WAPT. [This will make WAPT truly extensible and useful, making us capable to implement almost anything with it]//

I tried it with WAPT and came to know that it truly works! Now for me WAPT is highly extensible since I can implement almost anything with it!

1) I can use WAPT Javascript to implement extra testing logic. [Great!]

2) I can use WAPT Javascript to write debug logs [Great!]

3) I can use custom pages (written in any language) to incorporate extra testing logic and db clean up and transfer variables and data between pages that implement testing logic and WAPT [Great!]

(You guys should include some guidance and documentation regarding this extended possibility in your documentation. The beginners to software testing may badly miss this great possibility)

As of now the only possibility I am greatly missing is the ability to comment-out profiles, pages, variables etc that I don't want to use. Ability to activate/deactivate (comment/uncomment) profiles, pages, variables etc would have been a great possibility. As far as I am concerned, this is the prime and most important feature I would love to see get implemented in WAPT at the earliest. Can I get this feature at the earliest please!

Regards,

Sreenadh

 

Please, download the new build from http://www.loadtestingtool.com/forum/builds/WAPTPro2.0.zip. If you'll get an error message, let me know.

 

Share this post


Link to post
Share on other sites
3) I can use custom pages (written in any language) to incorporate extra testing logic and db clean up and transfer variables and data between pages that implement testing logic and WAPT [Great!]

What do mean by custom pages?

Share this post


Link to post
Share on other sites
Guest Sreenadh OG

Dear Sergei,

//What do mean by custom pages?//

I mean web pages (written in .net, php, jsp or whatever) where I can insert some extra testing logic. For example -

* In our application there is a page that posts an xml string to the server and gets back a an xml dataset. The ajax javascript code processes this dataset and creates a new xml string in another format and again sends it back to the server. Out of the above 3 transactions, WAPT will record the first request (i.e. sending of xml), it will record the response xml, and it will also record the next (3rd) xml request that that gets send to the server. As a tester my requirement was that I should be able to DYNAMICALLY repeat these steps with RANDOM data. In the current version of WAPT I can implement it in two ways -

1) Use java script: To create the initial string (1st xml) I am using a mix of (concatenated string of) static string, sequence, and ordered list (load from file). The (2nd xml) response from from server I am storing into a variable (defined by me) using the WAPT $search parameter function. To generate the next xml request (3rd xml) I am using a Javascript function to process the xml dataset (stored in the variable I defined) and is dynamically creating the xml I need. (The the web application under testing runs as usual, i.e. continues) This is one solution.

2) User a server side page (I am using Asp.net) written for testing purpose: To create the initial string (1st xml) I can use a mix of (concatenated string of) static string, sequence, and ordered list (load from file) [or I can even think of other solutions here]. The (2nd xml) response from from server I can store into a variable (defined by me) using the WAPT $search paramrdeter function. To generate the next xml request (3rd xml), I can pass this value to a custom .net page (i am using .net c#) written by me, to process the xml dataset (stored in the variable I defined) and is dynamically creating the xml I need. I can assign this value back to the application under testing and then the web application under testing runs as usual, i.e. continues. This is another solution. [This second root of using custom pages (i.e. pages written by tester for the sake of testing purpose alone) can be much useful in cases where I want to do some DB related work, get and give back values from WAPT, read data from server side text files and pass it to WAPT, dynamically generate test data, implement some extra testing logic etc etc]

Hope you understand my purpose and scenario.

 

That aside, let me give some feedback about the new version of that you provided me with.

1) It fails to playback pages which are stored in a directory with a space in directory name (This was working fine in the version of WAPT Pro 2.0 you have uploaded on 23rd March). Therefore I am unable to run my previously successfully recorded and ran scripts in it (because many of my directory names contains space in it)

2) In both the versions (i.e. the one uploaded on 23rd March and 26h March) in the end of installation screen there appears two check boxes with tick marks but the text is unreadable with a black box covering it. (Screen shot attached)

Please fix the first of these issues (i.e. space in folder name issue) first and please provide the updated build at the earliest. For the time being for evaluation purpose I have reverted to the old version itself (i.e. one uploaded on 23rd March).

In between I came to know of another issue (related to the version uploaded on 23rd March)

3) If I delete a URL parameter (post parameter) for any particular PAGE then the said URL parameter for ALL Pages gets removed!!! I wonder whether that is expected behavior or a major bug. I was expecting that if I modify the URL parameter for a page that would affect that page only and not the whole recording and all pages!

Regards,

Sreenadh

 

What do mean by custom pages?

 

Share this post


Link to post
Share on other sites
Guest Sreenadh OG

Dear Sergei,

Any update on the issues mentioned at this end of the below mail please?

Regards,

Sreenadh

 

Dear Sergei,

//What do mean by custom pages?//

I mean web pages (written in .net, php, jsp or whatever) where I can insert some extra testing logic. For example -

* In our application there is a page that posts an xml string to the server and gets back a an xml dataset. The ajax javascript code processes this dataset and creates a new xml string in another format and again sends it back to the server. Out of the above 3 transactions, WAPT will record the first request (i.e. sending of xml), it will record the response xml, and it will also record the next (3rd) xml request that that gets send to the server. As a tester my requirement was that I should be able to DYNAMICALLY repeat these steps with RANDOM data. In the current version of WAPT I can implement it in two ways -

1) Use java script: To create the initial string (1st xml) I am using a mix of (concatenated string of) static string, sequence, and ordered list (load from file). The (2nd xml) response from from server I am storing into a variable (defined by me) using the WAPT $search parameter function. To generate the next xml request (3rd xml) I am using a Javascript function to process the xml dataset (stored in the variable I defined) and is dynamically creating the xml I need. (The the web application under testing runs as usual, i.e. continues) This is one solution.

2) User a server side page (I am using Asp.net) written for testing purpose: To create the initial string (1st xml) I can use a mix of (concatenated string of) static string, sequence, and ordered list (load from file) [or I can even think of other solutions here]. The (2nd xml) response from from server I can store into a variable (defined by me) using the WAPT $search paramrdeter function. To generate the next xml request (3rd xml), I can pass this value to a custom .net page (i am using .net c#) written by me, to process the xml dataset (stored in the variable I defined) and is dynamically creating the xml I need. I can assign this value back to the application under testing and then the web application under testing runs as usual, i.e. continues. This is another solution. [This second root of using custom pages (i.e. pages written by tester for the sake of testing purpose alone) can be much useful in cases where I want to do some DB related work, get and give back values from WAPT, read data from server side text files and pass it to WAPT, dynamically generate test data, implement some extra testing logic etc etc]

Hope you understand my purpose and scenario.

 

That aside, let me give some feedback about the new version of that you provided me with.

1) It fails to playback pages which are stored in a directory with a space in directory name (This was working fine in the version of WAPT Pro 2.0 you have uploaded on 23rd March). Therefore I am unable to run my previously successfully recorded and ran scripts in it (because many of my directory names contains space in it)

2) In both the versions (i.e. the one uploaded on 23rd March and 26h March) in the end of installation screen there appears two check boxes with tick marks but the text is unreadable with a black box covering it. (Screen shot attached)

Please fix the first of these issues (i.e. space in folder name issue) first and please provide the updated build at the earliest. For the time being for evaluation purpose I have reverted to the old version itself (i.e. one uploaded on 23rd March).

In between I came to know of another issue (related to the version uploaded on 23rd March)

3) If I delete a URL parameter (post parameter) for any particular PAGE then the said URL parameter for ALL Pages gets removed!!! I wonder whether that is expected behavior or a major bug. I was expecting that if I modify the URL parameter for a page that would affect that page only and not the whole recording and all pages!

Regards,

Sreenadh

 

Share this post


Link to post
Share on other sites

Sorry for delay, we are preparing the version for release.

 

That aside, let me give some feedback about the new version of that you provided me with.

1) It fails to playback pages which are stored in a directory with a space in directory name (This was working fine in the version of WAPT Pro 2.0 you have uploaded on 23rd March). Therefore I am unable to run my previously successfully recorded and ran scripts in it (because many of my directory names contains space in it)

 

Fixed. You can download the new build from http://www.loadtestingtool.com/forum/builds/WAPTPro2.0.zip

 

2) In both the versions (i.e. the one uploaded on 23rd March and 26h March) in the end of installation screen there appears two check boxes with tick marks but the text is unreadable with a black box covering it. (Screen shot attached)

Please fix the first of these issues (i.e. space in folder name issue) first and please provide the updated build at the earliest. For the time being for evaluation purpose I have reverted to the old version itself (i.e. one uploaded on 23rd March).

In between I came to know of another issue (related to the version uploaded on 23rd March)

 

We can't reproduce this issue. What is your OS?

 

3) If I delete a URL parameter (post parameter) for any particular PAGE then the said URL parameter for ALL Pages gets removed!!! I wonder whether that is expected behavior or a major bug. I was expecting that if I modify the URL parameter for a page that would affect that page only and not the whole recording and all pages!

Regards,

Sreenadh

 

We can't reproduce this issue. Could you describe it in more details, please?

Share this post


Link to post
Share on other sites
Guest Sreenadh OG

Dear Sergei,

1) Thanks. I have already downloaded the version uploaded on 5th April - yes, the first issue (related to space in folder name) is fixed. Thanks. :)

2) Regarding second (minor) issue (i.e. end of installation screen there appears two check boxes with tick marks but the text is unreadable with a black box covering it) my OS Windows XP. The screen I am referring to is the screen that comes at the end of successful installation with the text "Installation Complete. Wapt Pro has been successfully installed. Press the finish button to exit the setup program". My question is what are the two check boxes with default tick marks that appear below? (The text written on the right of it is unreadable). Anyway, I used to press the "Finish" button and the setup completes successfully without any problem. I am unable to attach a screen shot here, that is why not attaching the same. This issue is present with the version uploaded on 5th April as well.

3) //If I delete a URL parameter (post parameter) for any particular PAGE then the said URL parameter for ALL Pages gets removed!// This seems to be a bug related to the version uploaded on 23th March only and that too related some specific scenario. The steps I followed were - * I inserted the duplicate of a page * Deleted some post parameters from it * Saved the test * Uninstalled Wapt version of 23rd March *Installed wapt version of 26th march *Due to the space in folder name bug, reverted to the version of 23rd march * When I opened the earlier text in WAPT the post parameters related to EVERY PAGE was missing! Anyway the good note is that - I DON'T find the same issue happening with the version of WAPT uploaded on 5th April. This issue seems to be fixed (or not present) in the version uploaded on 5th April. It is behaving as expected, and when I delete post parameters related to a page, it is affecting that page only. Fine! Thanks.

Note: I have advised our company to proceed with the purchase of WAPT Pro, and they would be purchasing it. Thanks for all the help and co-operation provided. :)

 

Thanks and Regards,

Sreenadh

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×