Jump to content
WAPT Forum
Sign in to follow this  
Guest Mike

WAPt does not recognize Java Script ShowModalDialog windows

Recommended Posts

Guest Mike

I have an application that uses the ShowModalDialog javascript command to display ASPX .Net web pages. WAPT does not recognize these pages while recording. Can you confirm this? Do I need an update?

 

Thank You

Share this post


Link to post
Share on other sites
Guest angela
I have an application that uses the ShowModalDialog javascript command to display ASPX .Net web pages. WAPT does not recognize these pages while recording. Can you confirm this? Do I need an update?

 

Thank You

 

Hi,

 

Now WAPT does not recognize such pages. Possibly, it will be implemented in one of our future releases.

Share this post


Link to post
Share on other sites
Guest labpas
I have an application that uses the ShowModalDialog javascript command to display ASPX .Net web pages. WAPT does not recognize these pages while recording. Can you confirm this? Do I need an update?

 

Thank You

 

 

We are having the same issue. Any client side javascript calls to window.showModalDialog are ignored by WAPT's recorder. This causes our WAPT testing to fail on these screens. Entire sections of server side code run from within these popups are not executed within the WAPT test because it does not launch the popup as is done when the test is recorded. It seems that without this feature, WAPT fails as a full featured web app load testing tool. Any hope this is supported in later versions? And the lack of WAPT executing client side Javascript is a severe hinderance to our web app testing (I would think most robust web apps would run into the same problem).

Share this post


Link to post
Share on other sites
Guest angela
We are having the same issue. Any client side javascript calls to window.showModalDialog are ignored by WAPT's recorder. This causes our WAPT testing to fail on these screens. Entire sections of server side code run from within these popups are not executed within the WAPT test because it does not launch the popup as is done when the test is recorded. It seems that without this feature, WAPT fails as a full featured web app load testing tool. Any hope this is supported in later versions? And the lack of WAPT executing client side Javascript is a severe hinderance to our web app testing (I would think most robust web apps would run into the same problem).

 

Please add the required requests manually, everything should work fine.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×