Jump to content


WAPT 5 run does not stop after prescribed time


  • Please log in to reply
2 replies to this topic

#1 Guest_Robert Ashworth_*

Guest_Robert Ashworth_*
  • Guests

Posted 29 May 2008 - 01:49 PM

The behaviour of the scenario run time setting seems to have changed in version 5.
If I set a value for 'run time', then after that time the run reports 'test is stopped' but web pages continue to be sent for some time afterwards. Further investigations suggest that each user completes the current session, completing any specified iterations. The rate of pages sent increases during this period, suggesting that the configured think time is ignored. The

#2 Guest_angela_*

Guest_angela_*
  • Guests

Posted 30 May 2008 - 10:28 AM

QUOTE (Robert Ashworth @ May 29 2008, 08:49 PM) <{POST_SNAPBACK}>
The behaviour of the scenario run time setting seems to have changed in version 5.
If I set a value for 'run time', then after that time the run reports 'test is stopped' but web pages continue to be sent for some time afterwards. Further investigations suggest that each user completes the current session, completing any specified iterations. The rate of pages sent increases during this period, suggesting that the configured think time is ignored. The


Hi Robert,

Most probably, you have the option "Stop test correctly" enabled. I described its work in details somewhere on the forum, so you can try to search for this description (you can use 'Search' option).

Also, such behaviour can be observed if you have a scenario with great amount of users ("Stop test correctly" is disabled), in this case WAPT can end its work in this way for freeing resources.


#3 Guest_Robert Ashworth_*

Guest_Robert Ashworth_*
  • Guests

Posted 19 June 2008 - 09:35 AM

Thank you. I did not notice this option. I will try a run with the option not set.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users