Jump to content


Socket error when verifying test


  • Please log in to reply
6 replies to this topic

#1 Guest_oidsman_*

Guest_oidsman_*
  • Guests

Posted 14 May 2008 - 07:30 PM

I have been using WAPT with no problems in my office situation behind a proxy etc. I want to repeat my tests from home to test perofrmance. The app is available publically with no problems. I have recorded the test from home (i.e. access to the site is fine) but when I verify the test I get the following error:-

"Failue: Socket Error 10060 Aconnection attempt failed because the connected party did not respond..."

I originally thought it was using proxy settings but I unticked this from the 'Settings screen' but I get the same error. The fact I can re cord properly indicates that the connection is actually OK.

Any help appreciated!

#2 Guest_angela_*

Guest_angela_*
  • Guests

Posted 15 May 2008 - 10:26 AM

QUOTE (oidsman @ May 15 2008, 02:30 AM) <{POST_SNAPBACK}>
I have been using WAPT with no problems in my office situation behind a proxy etc. I want to repeat my tests from home to test perofrmance. The app is available publically with no problems. I have recorded the test from home (i.e. access to the site is fine) but when I verify the test I get the following error:-

"Failue: Socket Error 10060 Aconnection attempt failed because the connected party did not respond..."

I originally thought it was using proxy settings but I unticked this from the 'Settings screen' but I get the same error. The fact I can re cord properly indicates that the connection is actually OK.

Any help appreciated!


Hello oidsman,

Regarding FAILURE: Socket error: 10060.

In general, such NET Errors relate to sockets/timeouts, so there are no standard recommendations on how to fix them. In order to resolve this issue, please try the following:

1) to configure your firewall properly (in case you are behind the firewall) in order to enable correct work of sockets;
2) to change your timeout (user think time) value set in WAPT. Try to increase user think time, it may have a positive effect, since little think time can result in various socket errors.




#3 Guest_TECHNOX_*

Guest_TECHNOX_*
  • Guests

Posted 16 January 2009 - 02:41 AM

Hi,

I am using WAPT for evaluation purpose. I did recorded the test and now verifying/testing the performance of the Web Application. I am getting the Network Error:
FAILURE: Socket error: 10060 - "A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond."

After reading the this thread, I have unchecked the Proxy Settings, so now no longer Using Proxy settings to perform the test. But it still resulted in above error.

Then, I increased the User think time from: 0 seconds to 70 seconds, but still no success.

Could you please suggest the work around for this.

Thank you in appreciation.

Tech

#4 Guest_angela_*

Guest_angela_*
  • Guests

Posted 16 January 2009 - 09:56 AM

QUOTE (TECHNOX @ Jan 16 2009, 08:41 AM) <{POST_SNAPBACK}>
Hi,

I am using WAPT for evaluation purpose. I did recorded the test and now verifying/testing the performance of the Web Application. I am getting the Network Error:
FAILURE: Socket error: 10060 - "A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond."

After reading the this thread, I have unchecked the Proxy Settings, so now no longer Using Proxy settings to perform the test. But it still resulted in above error.

Then, I increased the User think time from: 0 seconds to 70 seconds, but still no success.

Could you please suggest the work around for this.

Thank you in appreciation.

Tech



Hi Tech,

Please try to disable Keep Alive option in WAPT and send to us Full and Error logs if the problem remains.
Also, please let me know what is your webserver and what Keep Alive is set.


#5 Guest_TECHNOX_*

Guest_TECHNOX_*
  • Guests

Posted 18 January 2009 - 11:51 PM

QUOTE (angela @ Jan 16 2009, 09:56 AM) <{POST_SNAPBACK}>
Hi Tech,

Please try to disable Keep Alive option in WAPT and send to us Full and Error logs if the problem remains.
Also, please let me know what is your webserver and what Keep Alive is set.


Thank you Angela for your prompt reply.

I again tried to simulate the problem using Yahoo User Login. The problem still persist.

The Error log is as below:

<% 10:32:35 Header %>
Scenario:
Profile: UserLogin.wpp
Profile name: UserLogin

<% 10:32:35 Session(1) %>

<% 10:32:35 Main %>

<% 10:32:35 Page[page_1: http://mail.yahoo.com/](1) %>

<% 10:32:35 Connect %>
Connecting to remote host: mail.yahoo.com:80...

<% 10:32:56 Failure %>
FAILURE: Socket error: 10060 - "A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond."


Further, I am attaching the screen dumps, the error log and .wps file for the Test I have done.

I am surprised with this Network Error. Either, it should come when I was recording the actions for User Login, but it didn't. My concern is, why its coming, when its verifying or running the test!!!

Should you require anything else, please let me know. The test is critical for us and your cooperation will be highly appreciable.

Thank you,
Tech

Attached Files



#6 Guest_TECHNOX_*

Guest_TECHNOX_*
  • Guests

Posted 18 January 2009 - 11:59 PM

QUOTE (angela @ Jan 16 2009, 09:56 AM) <{POST_SNAPBACK}>
Hi Tech,

Please try to disable Keep Alive option in WAPT and send to us Full and Error logs if the problem remains.
Also, please let me know what is your webserver and what Keep Alive is set.


The Web Server is IIS v5.1

Tech

#7 Guest_angela_*

Guest_angela_*
  • Guests

Posted 19 January 2009 - 10:04 AM

QUOTE (TECHNOX @ Jan 19 2009, 05:59 AM) <{POST_SNAPBACK}>
The Web Server is IIS v5.1

Tech



Hi Tech,

The socket error occured because you tried to test mail.yahoo.com
It was taken by yahoo.com as DOS-attack and you were banned.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users