Jump to content
WAPT Forum
Sign in to follow this  
Guest Robert Ashworth

Problem transferring version 4 profile to version 5

Recommended Posts

Guest Robert Ashworth

I have a WAPT profile created using WAPT version 4. Each page has been amended to set the values of the __VIEWSTATE and __EVENTVALIDATION parameters to be 'hidden' values to avoid errors on playback. This script runs as expected on Version 4.

I have copied this scenario and profile to another PC on which WAPT 5 is installed. Running this consistently gives a viewstate error on page 3 of the profile:

 

Validation of viewstate MAC failed. If this application is hosted by a Web Farm.....

 

Is it not possible to run version 4 profiles on version 5, or do I have a different problem ?

Share this post


Link to post
Share on other sites
Guest angela
I have a WAPT profile created using WAPT version 4. Each page has been amended to set the values of the __VIEWSTATE and __EVENTVALIDATION parameters to be 'hidden' values to avoid errors on playback. This script runs as expected on Version 4.

I have copied this scenario and profile to another PC on which WAPT 5 is installed. Running this consistently gives a viewstate error on page 3 of the profile:

 

Validation of viewstate MAC failed. If this application is hosted by a Web Farm.....

 

Is it not possible to run version 4 profiles on version 5, or do I have a different problem ?

 

Hello Robert,

 

Now we are trying to find the reason of this. I will let you know as soon as possible.

 

Share this post


Link to post
Share on other sites
Guest angela
Hello Robert,

 

Now we are trying to find the reason of this. I will let you know as soon as possible.

 

It seems that the problem was due to the bug with __Viewstate which was fixed in our latest build. So please download it from our site www.loadtestingtool.com. If the problem remains, please let me know.

Share this post


Link to post
Share on other sites
Guest Robert Ashworth

The version shown on my WAPT.EXE file is 5.0.0.1 and the date stamp is 15.02/2008.

Is there a later version than this available ?

Share this post


Link to post
Share on other sites
Guest angela
The version shown on my WAPT.EXE file is 5.0.0.1 and the date stamp is 15.02/2008.

Is there a later version than this available ?

 

Yes, but it cannot be uploaded here due to the board limitation on files size. Could you send a letter to support@loadtestingtool.com? Or do you have an FTP server where I could upload the file?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×