Jump to content
WAPT Forum
Sign in to follow this  
Guest vivien tournel

Ajax Request and dynamic hidden variables.

Recommended Posts

Guest vivien tournel

Hi,

 

We have detected a litle issues, With the search of Dynamic data in Hidden fields. We are running an asp.net application. It sounds like dynamic data in hidden fields are detected without any problem during classic Postback or link. However if we do an Ajax Request, it sounds like the dynamic data in hidden field are not detected. This force us to declare all the time some hidden variable, wich is really a pain.

 

 

We are currently trying your product, we find it amazin. However, this last problem is really important for us and will define if we can buy your software.

 

all the best,

 

Vivien TOURNEL.

 

PS: We are using the microsoft Ajax Framework. and i download your last Package, following the link from your foruM

 

Share this post


Link to post
Share on other sites
Guest angela
Hi,

 

We have detected a litle issues, With the search of Dynamic data in Hidden fields. We are running an asp.net application. It sounds like dynamic data in hidden fields are detected without any problem during classic Postback or link. However if we do an Ajax Request, it sounds like the dynamic data in hidden field are not detected. This force us to declare all the time some hidden variable, wich is really a pain.

 

 

We are currently trying your product, we find it amazin. However, this last problem is really important for us and will define if we can buy your software.

 

all the best,

 

Vivien TOURNEL.

 

PS: We are using the microsoft Ajax Framework. and i download your last Package, following the link from your foruM

 

Hello Vivien,

 

Thank you for your nice words about WAPT!

We are aware of this issue, and currently we are working on this problem... I will let you know when it is fixed.

 

Meanwhile, please try to adjust the Search function in automatic parametrization. It may help as a temporary workaround.

Share this post


Link to post
Share on other sites
Guest vivien tournel

Thanks a lot for your fast answer... i am looking forward to be able to download the fixed version.

Any idea when this new version will be available ?

 

Vivien.

Share this post


Link to post
Share on other sites
Guest angela
Thanks a lot for your fast answer... i am looking forward to be able to download the fixed version.

Any idea when this new version will be available ?

 

Vivien.

 

Hello Vivien,

 

Please download the file named wapt50.exe from http://www.loadtestingtool.com/forum/files/

 

Let me know if the problem is fixed or remans. If the problem remains, please let me know in what mode Ajax works, synchronous or asynchronous one.

Share this post


Link to post
Share on other sites
Guest vivien tournel

Hi Angela,

 

Thanks for this new version, and this fast delivery, however i am still experiencing the same issue...

 

We are running in the classic microsoft asp.net mode, the asynchronous one, i attach to this ticket my scenario, you will see that many variable like viewstate and etc etc are not detected as dynamic.

 

All the best,

 

Vivien.

 

TestAjax.wps

Share this post


Link to post
Share on other sites
Guest angela
Hi Angela,

 

Thanks for this new version, and this fast delivery, however i am still experiencing the same issue...

 

We are running in the classic microsoft asp.net mode, the asynchronous one, i attach to this ticket my scenario, you will see that many variable like viewstate and etc etc are not detected as dynamic.

 

All the best,

 

Vivien.

 

 

Hi Vivien,

 

It is a pity. Could you please attach your Profile as well? Many thanks.

 

Share this post


Link to post
Share on other sites
Guest vivien tournel
Hi Vivien,

 

It is a pity. Could you please attach your Profile as well? Many thanks.

 

Please find attach the profile.

 

Vivien

TestMe.wpp

Share this post


Link to post
Share on other sites
Guest vivien tournel
Please find attach the profile.

 

Vivien

 

 

Any news on the problem guys ?

 

Vivien.

Share this post


Link to post
Share on other sites
Guest angela
Any news on the problem guys ?

 

Vivien.

 

Hi Vivien,

 

Could you please provide the Full Log of a successful operation and open an access to your application? If this is not possible, could you please provide us with the address of the server with an example of a similar usage?

 

Share this post


Link to post
Share on other sites
Guest angela
Hi Vivien,

 

Could you please provide the Full Log of a successful operation and open an access to your application? If this is not possible, could you please provide us with the address of the server with an example of a similar usage?

 

Hello Vivien,

 

In the process of investigating the problem we came to the conclusion that the above mentioned issue could not be fixed without redesign of the Recorder. So we are planning to fix the problem, but to do this simultaneously with recreation of WAPT Recorder. This fix will be available in the version that will follow our next version, i.e. not very soon, approximately in half a year. We are sorry for such inconvenience in your work and hope for your understanding.

 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×