Jump to content


Ajax Request and dynamic hidden variables.


  • Please log in to reply
9 replies to this topic

#1 Guest_vivien tournel_*

Guest_vivien tournel_*
  • Guests

Posted 22 September 2008 - 05:17 PM

Hi,

We have detected a litle issues, With the search of Dynamic data in Hidden fields. We are running an asp.net application. It sounds like dynamic data in hidden fields are detected without any problem during classic Postback or link. However if we do an Ajax Request, it sounds like the dynamic data in hidden field are not detected. This force us to declare all the time some hidden variable, wich is really a pain.


We are currently trying your product, we find it amazin. However, this last problem is really important for us and will define if we can buy your software.

all the best,

Vivien TOURNEL.

PS: We are using the microsoft Ajax Framework. and i download your last Package, following the link from your foruM


#2 Guest_angela_*

Guest_angela_*
  • Guests

Posted 23 September 2008 - 10:22 AM

QUOTE (vivien tournel @ Sep 23 2008, 12:17 AM) <{POST_SNAPBACK}>
Hi,

We have detected a litle issues, With the search of Dynamic data in Hidden fields. We are running an asp.net application. It sounds like dynamic data in hidden fields are detected without any problem during classic Postback or link. However if we do an Ajax Request, it sounds like the dynamic data in hidden field are not detected. This force us to declare all the time some hidden variable, wich is really a pain.


We are currently trying your product, we find it amazin. However, this last problem is really important for us and will define if we can buy your software.

all the best,

Vivien TOURNEL.

PS: We are using the microsoft Ajax Framework. and i download your last Package, following the link from your foruM


Hello Vivien,

Thank you for your nice words about WAPT!
We are aware of this issue, and currently we are working on this problem... I will let you know when it is fixed.

Meanwhile, please try to adjust the Search function in automatic parametrization. It may help as a temporary workaround.

#3 Guest_vivien tournel_*

Guest_vivien tournel_*
  • Guests

Posted 23 September 2008 - 02:55 PM

Thanks a lot for your fast answer... i am looking forward to be able to download the fixed version.
Any idea when this new version will be available ?

Vivien.

#4 Guest_angela_*

Guest_angela_*
  • Guests

Posted 03 October 2008 - 10:18 AM

QUOTE (vivien tournel @ Sep 23 2008, 09:55 PM) <{POST_SNAPBACK}>
Thanks a lot for your fast answer... i am looking forward to be able to download the fixed version.
Any idea when this new version will be available ?

Vivien.


Hello Vivien,

Please download the file named wapt50.exe from http://www.loadtesti...om/forum/files/

Let me know if the problem is fixed or remans. If the problem remains, please let me know in what mode Ajax works, synchronous or asynchronous one.

#5 Guest_vivien tournel_*

Guest_vivien tournel_*
  • Guests

Posted 06 October 2008 - 04:32 PM

Hi Angela,

Thanks for this new version, and this fast delivery, however i am still experiencing the same issue...

We are running in the classic microsoft asp.net mode, the asynchronous one, i attach to this ticket my scenario, you will see that many variable like viewstate and etc etc are not detected as dynamic.

All the best,

Vivien.

Attached Files



#6 Guest_angela_*

Guest_angela_*
  • Guests

Posted 07 October 2008 - 08:35 AM

QUOTE (vivien tournel @ Oct 6 2008, 11:32 PM) <{POST_SNAPBACK}>
Hi Angela,

Thanks for this new version, and this fast delivery, however i am still experiencing the same issue...

We are running in the classic microsoft asp.net mode, the asynchronous one, i attach to this ticket my scenario, you will see that many variable like viewstate and etc etc are not detected as dynamic.

All the best,

Vivien.



Hi Vivien,

It is a pity. Could you please attach your Profile as well? Many thanks.


#7 Guest_vivien tournel_*

Guest_vivien tournel_*
  • Guests

Posted 07 October 2008 - 08:46 AM

QUOTE (angela @ Oct 7 2008, 10:35 AM) <{POST_SNAPBACK}>
Hi Vivien,

It is a pity. Could you please attach your Profile as well? Many thanks.


Please find attach the profile.

Vivien

Attached Files



#8 Guest_vivien tournel_*

Guest_vivien tournel_*
  • Guests

Posted 09 October 2008 - 01:17 PM

QUOTE (vivien tournel @ Oct 7 2008, 10:46 AM) <{POST_SNAPBACK}>
Please find attach the profile.

Vivien



Any news on the problem guys ?

Vivien.

#9 Guest_angela_*

Guest_angela_*
  • Guests

Posted 15 October 2008 - 10:49 AM

QUOTE (vivien tournel @ Oct 9 2008, 08:17 PM) <{POST_SNAPBACK}>
Any news on the problem guys ?

Vivien.


Hi Vivien,

Could you please provide the Full Log of a successful operation and open an access to your application? If this is not possible, could you please provide us with the address of the server with an example of a similar usage?


#10 Guest_angela_*

Guest_angela_*
  • Guests

Posted 01 November 2008 - 10:05 AM

QUOTE (angela @ Oct 15 2008, 04:49 PM) <{POST_SNAPBACK}>
Hi Vivien,

Could you please provide the Full Log of a successful operation and open an access to your application? If this is not possible, could you please provide us with the address of the server with an example of a similar usage?


Hello Vivien,

In the process of investigating the problem we came to the conclusion that the above mentioned issue could not be fixed without redesign of the Recorder. So we are planning to fix the problem, but to do this simultaneously with recreation of WAPT Recorder. This fix will be available in the version that will follow our next version, i.e. not very soon, approximately in half a year. We are sorry for such inconvenience in your work and hope for your understanding.








0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users