Jump to content


500 server error


  • Please log in to reply
5 replies to this topic

#1 Guest_Arnold Conchas_*

Guest_Arnold Conchas_*
  • Guests

Posted 17 September 2008 - 04:45 PM

I'm getting an 500 internal server error everytime I run my script using wapt but the app works fine if we run the same process manually. This is what is being returned.

Server Error in '/Admin' Application.
--------------------------------------------------------------------------------

The state information is invalid for this page and might be corrupted.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Web.HttpException: The state information is invalid for this page and might be corrupted.

Source Error:


[No relevant source lines]


Source File: c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\admin\7b3cec50\c3e1ebe1\App_Web_tfgcnedv.1.cs Line: 0

Stack Trace:


[FormatException: Invalid character in a Base-64 string.]
System.Convert.FromBase64String(String s) +0
System.Web.UI.ObjectStateFormatter.Deserialize(String inputString) +67
System.Web.UI.ObjectStateFormatter.System.Web.UI.IStateFormatter.Deserialize(Str
ing serializedState) +4
System.Web.UI.Util.DeserializeWithAssert(IStateFormatter formatter, String serializedState) +37
System.Web.UI.HiddenFieldPageStatePersister.Load() +136

[ViewStateException: Invalid viewstate.
Client IP: 192.168.18.139
Port: 1651
User-Agent: *WAPT 5.0*
ViewState: %2FwEPDwULLTEwNTc1NzM3MzgPZBYCZg9kFgJmD2QWAmYPZBYEAgcPZBYCAgEPZBYCAgMPZBYCAgEPFgY
eEXByb2R1Y3RTZXJ2aWNlVXJsBSkvQWRtaW4vU2VydmljZXMvUHJvZHVjdHMuYXNteC9HZXRQcm9kdWN0
cx4Kc2VydmljZVVybAUyL0FkbWluL3NlcnZpY2VzL3NlcnZpY2VhcmVhcy5hc214L0dldENvdW50aWVzP
3NpZD0eB2VuY3R5cGUFE211bHRpcGFydC9mb3JtLWRhdGEWAgIDD2QWDgIBD2QWAgIJD2QWAgIBDw9kFg
IeA21heAUDMTUwZAIDD2QWAmYPZBYCAgcPEGQQFTQGU2VsZWN0AkFLAkFMAkFSAkFaAkNBAkNPAkNUAkR
DAkRFAkZMAkdBAkhJAklBAklEAklMAklOAktTAktZAkxBAk1BAk1EAk1FAk1JAk1OAk1PAk1TAk1UAk5D
Ak5EAk5FAk5IAk5KAk5NAk5WAk5ZAk9IAk9LAk9SAlBBAlJJAlNDAlNEAlROAlRYAlVUAlZBAlZUAldBA
ldJAldWAldZFTQGc2VsZWN0AkFLAkFMAkFSAkFaAkNBAkNPAkNUAkRDAkRFAkZMAkdBAkhJAklBAklEAk
lMAklOAktTAktZAkxBAk1BAk1EAk1FAk1JAk1OAk1PAk1TAk1UAk5DAk5EAk5FAk5IAk5KAk5NAk5WAk5
ZAk9IAk9LAk9SAlBBAlJJAlNDAlNEAlROAlRYAlVUAlZBAlZUAldBAldJAldWAldZFCsDNGdnZ2dnZ2dn
Z2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dkZAIFD2QWBAICDxBkEBU1B
lNlbGVjdApOYXRpb253aWRlAkFLAkFMAkFSAkFaAkNBAkNPAkN...]

[HttpException (0x80004005): The state information is invalid for this page and might be corrupted.]
System.Web.UI.ViewStateException.ThrowError(Exception inner, String persistedState, String errorPageMessage, Boolean macValidationError) +267
System.Web.UI.HiddenFieldPageStatePersister.Load() +218
System.Web.UI.Page.LoadPageStateFromPersistenceMedium() +83
System.Web.UI.Page.LoadAllState() +35
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +7350
System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +213
System.Web.UI.Page.ProcessRequest() +86
System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context) +18
System.Web.UI.Page.ProcessRequest(HttpContext context) +49
ASP.modules_vendor_companyinformation_aspx.ProcessRequest(HttpContext context) in c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\admin\7b3cec50\c3e1ebe1\App_Web_tfgcnedv.1.cs:0
System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Ex
ecute() +358
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +64




--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433

#2 Guest_angela_*

Guest_angela_*
  • Guests

Posted 18 September 2008 - 12:25 PM

QUOTE (Arnold Conchas @ Sep 17 2008, 11:45 PM) <{POST_SNAPBACK}>
I'm getting an 500 internal server error everytime I run my script using wapt but the app works fine if we run the same process manually. This is what is being returned.

Server Error in '/Admin' Application.
--------------------------------------------------------------------------------

The state information is invalid for this page and might be corrupted.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Web.HttpException: The state information is invalid for this page and might be corrupted.

Source Error:


[No relevant source lines]


Source File: c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\admin\7b3cec50\c3e1ebe1\App_Web_tfgcnedv.1.cs Line: 0

Stack Trace:


[FormatException: Invalid character in a Base-64 string.]
System.Convert.FromBase64String(String s) +0
System.Web.UI.ObjectStateFormatter.Deserialize(String inputString) +67
System.Web.UI.ObjectStateFormatter.System.Web.UI.IStateFormatter.Deserialize(Str
ing serializedState) +4
System.Web.UI.Util.DeserializeWithAssert(IStateFormatter formatter, String serializedState) +37
System.Web.UI.HiddenFieldPageStatePersister.Load() +136

[ViewStateException: Invalid viewstate.
Client IP: 192.168.18.139
Port: 1651
User-Agent: *WAPT 5.0*
ViewState: %2FwEPDwULLTEwNTc1NzM3MzgPZBYCZg9kFgJmD2QWAmYPZBYEAgcPZBYCAgEPZBYCAgMPZBYCAgEPFgY
eEXByb2R1Y3RTZXJ2aWNlVXJsBSkvQWRtaW4vU2VydmljZXMvUHJvZHVjdHMuYXNteC9HZXRQcm9kdWN
0
cx4Kc2VydmljZVVybAUyL0FkbWluL3NlcnZpY2VzL3NlcnZpY2VhcmVhcy5hc214L0dldENvdW50aWVz
P
3NpZD0eB2VuY3R5cGUFE211bHRpcGFydC9mb3JtLWRhdGEWAgIDD2QWDgIBD2QWAgIJD2QWAgIBDw9kF
g
IeA21heAUDMTUwZAIDD2QWAmYPZBYCAgcPEGQQFTQGU2VsZWN0AkFLAkFMAkFSAkFaAkNBAkNPAkNUAk
R
DAkRFAkZMAkdBAkhJAklBAklEAklMAklOAktTAktZAkxBAk1BAk1EAk1FAk1JAk1OAk1PAk1TAk1UAk5
D
Ak5EAk5FAk5IAk5KAk5NAk5WAk5ZAk9IAk9LAk9SAlBBAlJJAlNDAlNEAlROAlRYAlVUAlZBAlZUAldB
A
ldJAldWAldZFTQGc2VsZWN0AkFLAkFMAkFSAkFaAkNBAkNPAkNUAkRDAkRFAkZMAkdBAkhJAklBAklEA
k
lMAklOAktTAktZAkxBAk1BAk1EAk1FAk1JAk1OAk1PAk1TAk1UAk5DAk5EAk5FAk5IAk5KAk5NAk5WAk
5
ZAk9IAk9LAk9SAlBBAlJJAlNDAlNEAlROAlRYAlVUAlZBAlZUAldBAldJAldWAldZFCsDNGdnZ2dnZ2d
n
Z2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dnZ2dkZAIFD2QWBAICDxBkEBU1
B
lNlbGVjdApOYXRpb253aWRlAkFLAkFMAkFSAkFaAkNBAkNPAkN...]

[HttpException (0x80004005): The state information is invalid for this page and might be corrupted.]
System.Web.UI.ViewStateException.ThrowError(Exception inner, String persistedState, String errorPageMessage, Boolean macValidationError) +267
System.Web.UI.HiddenFieldPageStatePersister.Load() +218
System.Web.UI.Page.LoadPageStateFromPersistenceMedium() +83
System.Web.UI.Page.LoadAllState() +35
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +7350
System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +213
System.Web.UI.Page.ProcessRequest() +86
System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context) +18
System.Web.UI.Page.ProcessRequest(HttpContext context) +49
ASP.modules_vendor_companyinformation_aspx.ProcessRequest(HttpContext context) in c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\admin\7b3cec50\c3e1ebe1\App_Web_tfgcnedv.1.cs:0
System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Ex
ecute() +358
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +64




--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433


Hi,

In the request page_10 the field “method” is empty (the method itself is not selected). Please try to enter “Post” there and run the test. Please let me know if the problem remains.



#3 Guest_Arnold Conchas_*

Guest_Arnold Conchas_*
  • Guests

Posted 18 September 2008 - 05:44 PM

QUOTE (angela @ Sep 18 2008, 05:25 AM) <{POST_SNAPBACK}>
Hi,

In the request page_10 the field “method” is empty (the method itself is not selected). Please try to enter “Post” there and run the test. Please let me know if the problem remains.


I tried that option and the problems still exist

#4 Guest_angela_*

Guest_angela_*
  • Guests

Posted 19 September 2008 - 09:32 AM

QUOTE (Arnold Conchas @ Sep 19 2008, 12:44 AM) <{POST_SNAPBACK}>
I tried that option and the problems still exist



Please try the special build uploaded here:

http://www.loadtesti...om/forum/files/



#5 Guest_Arnold Conchas_*

Guest_Arnold Conchas_*
  • Guests

Posted 19 September 2008 - 06:26 PM

QUOTE (angela @ Sep 19 2008, 01:32 AM) <{POST_SNAPBACK}>
Please try the special build uploaded here:

http://www.loadtesti...om/forum/files/


It turns out that WAPT recors a maximum of 19 fields. Is that correct? so we entered the rest manually.

- Most of the requests should be “POST” instead of “GET”. The recorder is recording them wrong. I switched a couple .. not sure if it was required or not. For sure, if you are uploading an image, it MUST be POST.
- when recording, it is only recording up to 19 fields. I added the others manually, and it worked. I used jmeter to record, so I knew what the other fields were, copied them over, and then it worked.

#6 Guest_angela_*

Guest_angela_*
  • Guests

Posted 22 September 2008 - 07:56 AM

QUOTE (Arnold Conchas @ Sep 20 2008, 01:26 AM) <{POST_SNAPBACK}>
It turns out that WAPT recors a maximum of 19 fields. Is that correct? so we entered the rest manually.

- Most of the requests should be “POST” instead of “GET”. The recorder is recording them wrong. I switched a couple .. not sure if it was required or not. For sure, if you are uploading an image, it MUST be POST.
- when recording, it is only recording up to 19 fields. I added the others manually, and it worked. I used jmeter to record, so I knew what the other fields were, copied them over, and then it worked.


Hello,

The program should not record only 19 fields, as well as use GET instead of POST.

Please let me know where exactly the parameters were recorded not correctly, and in which requests incorrect methods were used.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users