Jump to content
WAPT Forum
Guest detux

Ordered List Issue

Recommended Posts

Guest detux

Hi,

 

I have created a file with a list of barcodes.

 

e.g.

792399487

792399499

792399507

792399519

792399520

792399532

792399544

 

The issue that I am having is that rather than iterating through the list of numbers, the first value is read over and over again in the test.

 

The number of user sessions to complete is 10.

 

The result shows that, in this example, 792399487 is posted 10 times rather than 792399487 --> 792399499 ...

 

Any suggestions would be appreciated.

 

Thanks.

 

 

 

 

Share this post


Link to post
Share on other sites
Guest osa

the only way you can iterate on the ordered list are on user and on iteration.

 

maybe you should replicate main of your profile...or if you have sequenzial barcode, you could use the function Sequence that iterate on user and iteration, but there is a problem. The sequence could not read by a file but it's generate from a math formula.

Share this post


Link to post
Share on other sites
Guest detux

Thx. for your replies.

 

I will not be in a position to release my test profile due to privacy reasons but I have attached a screenshot of the same.

 

I was under the impression that the code base in WAPT would be able to read and iterate through the barcodes or tokens in the file with every request made to the server. Please correct me if this is not the case.....

 

As suggested by 'OSA', the sequence would not work in my case and replicating main 55000 times would take me forever.

 

Any other suggestions will be much appreciated....Thanks.

 

 

 

 

 

 

 

 

 

 

post-141-1215044866.jpg

Share this post


Link to post
Share on other sites
Guest rbidner
Thx. for your replies.

 

I will not be in a position to release my test profile due to privacy reasons but I have attached a screenshot of the same.

 

I was under the impression that the code base in WAPT would be able to read and iterate through the barcodes or tokens in the file with every request made to the server. Please correct me if this is not the case.....

 

As suggested by 'OSA', the sequence would not work in my case and replicating main 55000 times would take me forever.

 

Any other suggestions will be much appreciated....Thanks.

 

I see exactly the same issue in my testing - When I select iteration I get the first value in the list for each user and for every iteration. When I select users i see the ordered list return the first value for the first user and the second value for the second user etc as expected. The iteration parameter on ordered list variable seems not to work?

 

Has there been any resolution to this issue?

Share this post


Link to post
Share on other sites
Guest angela
I see exactly the same issue in my testing - When I select iteration I get the first value in the list for each user and for every iteration. When I select users i see the ordered list return the first value for the first user and the second value for the second user etc as expected. The iteration parameter on ordered list variable seems not to work?

 

Has there been any resolution to this issue?

 

 

Please try to update WAPT first, and if the issue remains in the new build, send to support (or upload here) your Profile and Scenario. As you can see, we cannot find the reason of the problem without some additional information. Thanks in advance.

Share this post


Link to post
Share on other sites
Guest rbidner
Please try to update WAPT first, and if the issue remains in the new build, send to support (or upload here) your Profile and Scenario. As you can see, we cannot find the reason of the problem without some additional information. Thanks in advance.

 

 

I am using the Jan 29, 2009 build is there a newer one I should be using?

 

If not I have sent the profile and scenario to support along with the logs that show the iterations are not changing the value based on the Ordered List.

 

Thanks

Bob

 

Share this post


Link to post
Share on other sites
Guest angela
I am using the Jan 29, 2009 build is there a newer one I should be using?

 

If not I have sent the profile and scenario to support along with the logs that show the iterations are not changing the value based on the Ordered List.

 

Thanks

Bob

 

Yes, this is the latest one.

Share this post


Link to post
Share on other sites
Guest fernandomic

So, could you identify if this is an issue or what to do????

 

I have the same problem!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×