Jump to content
WAPT Forum
Sign in to follow this  
Guest Mahes

Not supporting more then 4 Profiles

Recommended Posts

Guest Mahes

I created 5 user profiles. When I given for Run Test :-

 

1. What I found:-

 

i. It is not doing function on sequence wise of the Profiles I added in the Navigation Pane, means i.e. Profile1, Profile2,

Profile3 etc.

 

ii. It is Jumping from one Profile to Another Profile i.e. Profile2, Profile3 then Profile1 etc.. or leaving some

Profile function.( Not having any action). Not in sequence wise i.e. Profile1, Profile2, Profile3 etc..

 

iii. Partially doing some Profile functions. (Some Profiles have full functionality and some Profile have Partially)

 

2. What I wants:-

 

i. It should Run from the Profile1 then continue upto Profile5 (Profile1,Profile2.... Profile5).

ii. It should do all functions of all Profiles, As I given sufficient time to finish one profiles functionality,

iii. It should not repeat any Profile Funcitonality.

 

3. What I did for settings :-

i. I created/ recorded One Profile and browse the pages, All total 10 pages in One profile. (From Login to Last page).

ii. All pages I kept in Main actions.

iii. I copy the recorded Profile and Make 5 Duplicate Profile.

iv. I given Login info. on the variables, so that it can login in each profile.

v. I given 20 minutes time with 5 Users Profile, with step 1 every 2 minutes.

 

Can you advise please on my above problem.

 

Thanks in advance.

 

With regards,

Mahes.

Share this post


Link to post
Share on other sites
Guest angela

Hello Mahes,

 

Please send to us your scenario, profile, full and error logs generated by WAPT.

 

As for each point from your message:

 

1. All profiles are executed simultaneously.

2. The log is required.

3. Do you mean that in one profile WAPT executed several sessions?

Share this post


Link to post
Share on other sites
Guest Mahes
Hello Mahes,

 

Please send to us your scenario, profile, full and error logs generated by WAPT.

 

As for each point from your message:

 

1. All profiles are executed simultaneously.

2. The log is required.

3. Do you mean that in one profile WAPT executed several sessions?

 

 

Hi
Angela,
[/color]
1. Yes, it is gradually increasing one by one, if the 1st Profile job not finish also it will jump to some other profile, means it is working with random type. With this the last report will give, out of 5 User Profile 3-4 user profile ok with repeating, and 1-2 user profile partially or not at all.
I am running on User load --> Ramp-up types users from 0 - 5, with step 1 every 1.00 minutes.
Even if I change 2 minutes also same answer instead of 1.00 minutes.
2. Please find attach herewith the log file (.zip).
3. Yes, sometimes one or more then one Profiles, it depends on Run time for 5 users, if Run time more, then, more User Profiles will execute several sessions where as some profile are not working at all or partially working.
Please advise if any thing I need to change. I want to run smoothly with 20 users profile.
Thanks,
With regards,
Mahes.

FiveUserTest.zip

Share this post


Link to post
Share on other sites
Guest angela

Hello Mahes,

 

If you wish to execute one session for one user (with 5 profiles), you need to select the following settings:

 

Number of user sessions to complete = 5

Fixed user load = 5

 

In the table in which you distribute the users between profiles you need to set 1 user for each profile. Thus, for 20 profiles you need to select Number of user sessions to complete = 20 and Fixed user load = 20. However, the profiles will be executed simultaneously.

 

Also, you can create 1 profile, in profile properties set Iterations = 20, specify for each user login and password with use of function Ordered list and parameters,

and in properties adjust the settings so that values should be changed for each iteration.

 

In Test volume specify Number of user sessions to complete = 1 and Fixed user load = 1. On the above conditions one session will be executed for the profile with different user data, and iterations will be executed sequentially.

 

 

Share this post


Link to post
Share on other sites
Guest Mahes
Hello Mahes,

 

If you wish to execute one session for one user (with 5 profiles), you need to select the following settings:

 

Number of user sessions to complete = 5

Fixed user load = 5

 

In the table in which you distribute the users between profiles you need to set 1 user for each profile. Thus, for 20 profiles you need to select Number of user sessions to complete = 20 and Fixed user load = 20. However, the profiles will be executed simultaneously.

 

Also, you can create 1 profile, in profile properties set Iterations = 20, specify for each user login and password with use of function Ordered list and parameters,

and in properties adjust the settings so that values should be changed for each iteration.

 

In Test volume specify Number of user sessions to complete = 1 and Fixed user load = 1. On the above conditions one session will be executed for the profile with different user data, and iterations will be executed sequentially.

 

Hi

 

Angela,

 

Please find attach herewith the output and script file for your reference.

 

Thanks for your help.

 

Actually I wants to run 20 users simultaneously for 30 minutes and I created 20 user profiles.
[/color]
What I did:-
1. I recorded one profile and Duplicate 20 times for 20 User profile, then change their each user Id.
Note :- For full record of One UserProfile is taking 3-4 minutes.
What I want:-
1. I wants to run 20 userProfile for 30 minutes with Ramp-up system. So that my graph should display 20 user profile running for 30 minutes.
Is it possible during Ramp-up time it will reduce the running time of each userProfile in compairsion to their Recorded time. Because as per recorded time 20 user will take around 60-80 minutes to complete.
What I am getting:-
1. After recording when I run for 30 minutes with Ramp-up 20 userProfile with step 1 every 15 seconds, It is not at all giving the output as per I recorded the script. Even after running 30 minutes also not fulfilling a single UserProfile as per recorded.
Can you please suggest me where I am wrong.
While running Ramp-up system, Is it means it will run randomly like i.e. Profile1, Profile4, Profile17 etc.. with partially done functionality of Profile1, Profile4 and Profile17 etc.. or it will run full functionality of Profile1, Profile4, Profile17 etc.. with each profile finish the whole functionality.
When I am running less profile with more time, I am getting each Profile performing partially of their functionality and sometimes some Profiles repeating and some profiles not doing any work at all.I dont know where I am wrong in settings. Can you please help me.

 

Thanks in advance,

 

With regards,

Mahes.

 

 

 

 

20UserProfile.zip

Share this post


Link to post
Share on other sites
Guest Mahes
I believe that it will be helpful for you to read my reply to another topic:

http://www.loadtestingtool.com/forum/index...9entry309

It may help you to create a right scenario.

 

Also, please send to us Full and Error logs, so that we can see why some profiles are not executed.

 

 

Hi
Angela,
[/color]
Please find attach herewith my Scenario, Log file and Output.
I am testing with 10 users with Fixed user load or Ramp-up with every 1 minutes and Run Time - 30 minutes. Getting output partially, means some users doing full functionality upto last point and some users throughing the following error and just doing the 1 or 2 steps of recorded functionality out of 5 steps in my recorded script. You can see in the output.
I am using Tomcat 5.5.16 as my application server.
I set Maximum time of waiting Server response -- 1000 seconds (which is max from WAPT).
I set Maximum time of waiting Socket operation -- 1000 seconds (which is max from WAPT).
Still I am frequently getting the connection error problem. I cannot find out where is the problem.
1.<% 11:12:45 Response-Failed(500) %>

HTTP/1.1 500 Internal Server Error

Server: Apache-Coyote/1.1

Content-Type: text/html;charset=utf-8

Content-Length: 2796

Date: Sun, 22 Jun 2008 03:12:45 GMT

Connection: close

2. <% 11:12:44 Failure %>

FAILURE: Socket error: 10060 - "A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond."

<% 11:12:44 Stopping %>

3. <% 11:19:10 Session(1) %><% 11:19:10 Main %><% 11:19:10 Page[page_1: http://localhost:8080/iexpense/index.jsp](1) %><% 11:19:10 Connect %>

Connecting to remote host: localhost:8080...<% 11:19:11 Page[page_2: http://localhost:8080/iexpense/main.do](1) %><% 11:22:53 Page[page_3: http://localhost:8080/iexpense/ExpenseDtl/add.do](1) %><% 11:34:07 Page[page_4: http://localhost:8080/iexpense/ExpenseDtl/addItem.do](1) %><% 11:48:22 Stopping %><% 11:48:22 Page[page_5: http://localhost:8080/iexpense/ExpenseDtl/view.do](1) %><% 11:52:34 Stopping %><% 11:52:34 Page[page_6: http://localhost:8080/iexpense/ExpenseDtl/save.do](1) %>

Note:- You can see Stoping and partially doing functionality.

4. Sometimes I check in the tomcat consol also, for some UserProfile session it was trying to repeat the same functionality and throughing error (but rare case). I am confirm that my application is correct because while I am doing operation on my web application I am not getting any error. There are so many other errors also, you can find out in log file. Please help me.

Thanks in advance. With regards,Mahes.

Share this post


Link to post
Share on other sites
Guest angela

 

Mahes,

 

We need Full and Error logs (I sent you a letter where I described how to generate them).

 

Please let me know if the errors occur in each session or not.

 

Also, please check the settings on your server (timeout and keep-alive). Possibly the errors occur due to bad connection.

 

Share this post


Link to post
Share on other sites
Guest Mahes
Hi
Sorry for not attached the error log last time.
[/color]
This time I added all Error log, Result set, Scenario into the .zip file. Please download this file and unzip, you can get all files.
I tested with the following scenario.
1. No of Users : 20 Users
2. Ran Time : 30 minutes.
3. Ramp-up with step 1 every 30 seconds.
4. Refresh time : 30 seconds.
Global settings :-
1. Server Response :- 1000 seconds.
2. Socket Operation : 1000 seconds.
Result found :- Partially OK, Partially Not.
Yes, It is creating more then one session for One Virtual User.
Mostly Found the following errors :-
1. 500 Internal Server Error
2. Socket error: Receive timeout
3. FAILURE: Socket error: 10060 - "A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond."
Please help me.
Thanks in advance.
With regards,
Mahes.

Share this post


Link to post
Share on other sites
Guest gloryforixseal

update:

i found that by ticking the "Ignore permissions on this volume" in the "get info" for my home directory, project x can see the files. however, this is not an acceptable option since it means that any user on this computer can see my files. i will investigate the problem further but would still be gratefull for any help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×