Jump to content


Cannot record JSON requests?


  • Please log in to reply
2 replies to this topic

#1 Guest_Paul Deen_*

Guest_Paul Deen_*
  • Guests

Posted 21 May 2008 - 10:55 AM

It seems that WAPT struggles recording JSON (standard web service call with ASP.NET AJAX)

When using HTTP Fiddler and IE directly, I can see the successful POST data looks like this:
{"helpId":"posadrn","helpTitle":"Address"}

However, using WAPT, it seems to encode that POST data, so it looks like:

%7B%22helpId%22%3A%22posadrn%22%2C%22helpTitle%22%3A%22Address%22%7D

Which is immediately rejected by the server.

I created a new request and put in the JSON code into the POST field directly; it does exactly the same thing. Is there any way to work around this?

Thanks,

Paul

#2 Guest_angela_*

Guest_angela_*
  • Guests

Posted 22 May 2008 - 08:33 AM

QUOTE (Paul Deen @ May 21 2008, 05:55 PM) <{POST_SNAPBACK}>
It seems that WAPT struggles recording JSON (standard web service call with ASP.NET AJAX)

When using HTTP Fiddler and IE directly, I can see the successful POST data looks like this:
{"helpId":"posadrn","helpTitle":"Address"}

However, using WAPT, it seems to encode that POST data, so it looks like:

%7B%22helpId%22%3A%22posadrn%22%2C%22helpTitle%22%3A%22Address%22%7D

Which is immediately rejected by the server.

I created a new request and put in the JSON code into the POST field directly; it does exactly the same thing. Is there any way to work around this?

Thanks,

Paul


Hi Paul,

In the Profile properties there is an option "Encode request parameters" set by default, please try to disable it and see if the problem remains.


#3 Guest_Paul Deen_*

Guest_Paul Deen_*
  • Guests

Posted 22 May 2008 - 09:50 AM

QUOTE (angela @ May 22 2008, 09:33 AM) <{POST_SNAPBACK}>
Hi Paul,

In the Profile properties there is an option "Encode request parameters" set by default, please try to disable it and see if the problem remains.


Hi Angela.

Yes, this allows the json request to run, however, this option is done at profile level rather than request. If I turn it off, the JSON request runs great, but the rest of the request crash and burn. Is there any intention to be able to override this at request level?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users