Jump to content
WAPT Forum
Sign in to follow this  
Guest Noregon

Large number of Network errors (10051) during Ramp-up test

Recommended Posts

Guest Noregon

I have created a test scenario with several profiles. When I run a test on any given profile, I get numerous Network Errors during the test for the first page request. All of them report as [Network error: 10051 - "A socket operation was attempted to an unreachable network."]. The errors start occurring when the user load is increased, but doesn't occur for every user. The first error generally occurs for User3 when load first increases from 2 to 4; they continue to occur for other non-specific users that are created as the ramp-up continues. To test the connection, I created a BAT file that loops a WGET command continuously to the same server and ran it concurrently in 4 separate processes (DOS command shell windows); all returned success, but occasionally would pause a second or two waiting to resolve the DNS name or get the server response. I am attaching the user profile as well as the logs (for 1st & 3rd user).

Thanks for your help.

 

Client/Load Machine Specifics:

Windows 7, 64-bit, w/ SP1

i5 CPU 2.67GHz, 4GB RAM

WAPT Pro 2.5, build 5/18/12 w/ ASP.NET module

 

Webserver Details:

Server running at remote location that we are contracting to

I had IT check router/firewall and they say the requests are not being blocked (they say the requests are logged as potential w/ warning, but not blocked)

IT checked server performance and says server doesn't appear to be at critical load

WAPT SNMP counters indicate server performance criteria is OK.

 

Scenario/Profile Details:

Ramp-Up from 2 to 10, w/ step 2 every 12secs for a run-time of 01:00

For this test, I only selected to run 1 profile

I've tried increasing user-think time for the first request from (0 to 1) to (5-10); less sessions (expected), but still get network errors

I've tried setting "Server response valid if response time is less than" to 5000 and 10000 (5sec & 10sec); no affect

I've tried changing the "Wait seconds after session failure" from 1 to 5secs; less failed sessions (expected, but still get network errors

I've turned on and off the "Keep alive server connection" with no affect

WAPT_Test.zip

Share this post


Link to post
Share on other sites
Guest Noregon

Sergei, thank you for your response.

 

We did have IP spoofing turned on in the Load Agent. I turned it off and now everything works; there are no network errors.

So why would having IP spoofing turned on cause network errors?

 

Thanks for your help!

Jimmy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×