Jump to content


"an established connection was aborted.." from load agent


  • Please log in to reply
4 replies to this topic

#1 Guest_jstaffans_*

Guest_jstaffans_*
  • Guests

Posted 21 October 2011 - 09:30 AM

Hi!

I run WAPT Pro on my workstation and a load agent on a separate machine (both running Windows 7). For some reason, the load agent will disconnect after about five minutes with a "an established connection was aborted by the software in your host machine" error, causing the test run to fail.

I'm pretty sure it isn't a firewall issue because

a) the test runs for five minutes before the load agent disconnects and
B) there is an exception for the load agent in the host firewall.

Any ideas?

Best regards,
Johannes

#2 Sergei Leonov

Sergei Leonov

    Advanced Member

  • Administrators
  • PipPipPip
  • 663 posts

Posted 21 October 2011 - 10:57 AM

What build of WAPT Pro do you use and what are the test settings?
Sergei Leonov
WAPT Project Manager
SoftLogica LLC

Office: +7-383-335-6692
Toll-free: 1-888-364-6797 (for US only)
Time zone GMT +6, EST +11
E-mail: support@loadtestingtool.com
http://www.loadtestingtool.com

#3 Guest_jstaffans_*

Guest_jstaffans_*
  • Guests

Posted 21 October 2011 - 12:06 PM

I haven't changed any test settings, basically I've just recorded a profile for testing purposes and ran it. Any particular test settings you're interested in?

As for the build, the help dialog says "WAPT Pro 2.5 Built on Oct 7, 2011".

I might have to take back my statement about the firewall, I turned it off on the remote machine hosting the load agent and now the connection seems to be stable. Still, it would be nice to know what is causing the issue.

#4 Sergei Leonov

Sergei Leonov

    Advanced Member

  • Administrators
  • PipPipPip
  • 663 posts

Posted 24 October 2011 - 08:16 AM

It means that your firewall was overloaded during the test.
Sergei Leonov
WAPT Project Manager
SoftLogica LLC

Office: +7-383-335-6692
Toll-free: 1-888-364-6797 (for US only)
Time zone GMT +6, EST +11
E-mail: support@loadtestingtool.com
http://www.loadtestingtool.com

#5 Guest_jstaffans_*

Guest_jstaffans_*
  • Guests

Posted 25 October 2011 - 08:44 AM

makes sense. thanks for the reply!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users