Jump to content
WAPT Forum
Sign in to follow this  
Guest Bach Nguyen

Explain on 02 types of response time

Recommended Posts

Guest Bach Nguyen

HI,

 

I have 2 questions regading the values of response time as following:

 

1) Is there anyone help me to explain in detail on 02 types of response time as showing in summary report:

 

What does the values in paraenthesis and the values NOT in paraenthesis? As i see in my summay report, the average response time with all page elements of a transaction is 3s but in fact, as i manually see in the computer lock, the tracsaction always take at least 7s to complete ( completelly downloaded and displayed all items in client web-browse). What is the difference bettwen 02 numbers?

 

2) How does WAPT work? As my observation, the tool seems only to hook on to server when i record the profile and it does hook to the application for verifying and testing times. I found this matter as i does not see the log information for the tested transactions on server when i try to run the test script.

 

Thank in advance.

Share this post


Link to post
Share on other sites

HI,

 

I have 2 questions regading the values of response time as following:

 

1) Is there anyone help me to explain in detail on 02 types of response time as showing in summary report:

 

What does the values in paraenthesis and the values NOT in paraenthesis? As i see in my summay report, the average response time with all page elements of a transaction is 3s but in fact, as i manually see in the computer lock, the tracsaction always take at least 7s to complete ( completelly downloaded and displayed all items in client web-browse). What is the difference bettwen 02 numbers?

 

2) How does WAPT work? As my observation, the tool seems only to hook on to server when i record the profile and it does hook to the application for verifying and testing times. I found this matter as i does not see the log information for the tested transactions on server when i try to run the test script.

 

Thank in advance.

 

Most probably the problems appear because you have not parameterized the HTTP requests in your profile after recording it. Note that initially all requests are recorded as is. If you use a recorded profile without modifications, WAPT will simply repeat all the same requests with the same values of all parameters. However when working with dynamic site content, some parameters should have unique values for each session. The values of such parameters should be extracted from server response to the previous requests. You can read more about that using the following two links.

http://www.loadtestingtool.com/help/working-with-session-variables.shtml

http://www.loadtestingtool.com/help/parameter-value-dynamic-calculation.shtml

 

(Note: The above links refer to WAPT Pro 2.0. If you use other version of the product, some GUI elements can be different, but the whole concept is the same. You can also find corresponding topics in the help file provided with your product.)

 

Recently we also created a demo clip showing step by step how to perform the parameterization. You can download it here: http://www.loadtestingtool.com/quickstart/WAPTdemo.avi

 

Also, I recommend you to use the "Verify test" button to check your profiles before running the test. It will execute each profile one time and log all the details. After the verification is finished you can expand the "Logs" folder in the left view. You will see all the requests and server responses logged during the profile execution. You can also use logs for test runs, but you need to choose the level of details on the “Log and Report Settings” page.

 

Note also that when you record a profile, you should start from the very first URL that you use to access the web site. If you start recording from a page inside a user session, your profile will be incomplete and will not produce a valid session during the test.

 

If you still cannot find the reason of the problem, please send your profile (.wpp file) and log file with the test verification data to support. To save logs right click on the Logs folder and choose "Save Logs" from the menu.

Share this post


Link to post
Share on other sites
Guest Bach Nguyen

Many thanks for your answer on question #2. You figured out my problem.

 

How's about the question #1. I still make me confused with the time generated by the tool and the actual time as i counted in computer lock.Thanks,

Share this post


Link to post
Share on other sites

Many thanks for your answer on question #2. You figured out my problem.

 

How's about the question #1. I still make me confused with the time generated by the tool and the actual time as i counted in computer lock.Thanks,

 

Check the WAPT log. You need to be sure that your profile works correctly before you will compare results of testing. Often times are different because some errors occurred during a test.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×