Jump to content
WAPT Forum
Sign in to follow this  
Guest ndoccia

WAPT 7.0 crashes when using windows integrated authentication

Recommended Posts

Guest ndoccia

Hi guys,

I've just downloaded WAPT 7.0 ( trial version) and I'm trying to create a scenario in order to test a web application using Integrated Windows Authentication.

 

I've enabled the support for authentication in profile's preferences, but when i try to record a request for the profile two things happens:

1) the usual dialog box pop up requiring username and password

2) when I insert credentials WAPT crashes.

 

If I cancel the authentication dialog recording is successfull.

 

More details: the web application is hosted on a Windows Server 2008 R2, and I tried to create records for user profile from a Windows Server 2008 R2 host and from a Windows XP host, still with the same result.

 

In the following the details obtained from the fault happened on the Windows Server 2008 R2 host:

 

Problem signature:

Problem Event Name: BEX

Application Name: WAPT.exe

Application Version: 7.0.0.1

Application Timestamp: 4d08693d

Fault Module Name: WAPT.exe

Fault Module Version: 7.0.0.1

Fault Module Timestamp: 4d08693d

Exception Offset: 003e43ed

Exception Code: c0000409

Exception Data: 00000000

OS Version: 6.1.7600.2.0.0.274.10

Locale ID: 1040

Additional Information 1: 78a5

Additional Information 2: 78a5427b0519481ee77ca457e58cb3f2

Additional Information 3: 4f34

Additional Information 4: 4f3424f6d8d50569961d3b7c9aa76306

 

Have you got any suggestions?

 

P.s. please sorry for my poor english :rolleyes:

 

Share this post


Link to post
Share on other sites
Guest ndoccia
Please, find a crash report file (crashreport.txt) in WAPT installation folder and sent it to support@loadtestingtool.com

 

Hi Sergei, I'm not able to find any crash report file in the WAPT installation folder.

I've downloaded WAPTPro 2.1 and it doesn't show the same problem.

How can I obtain more information about program crashes?

 

Thank you

Share this post


Link to post
Share on other sites
Guest SanjP

 

Hi, I am having a similar requirement. I have installed the WAPT 7, as in the link above. I want to do performance test on an intranet web application which has windows authentication. With WAPT, I create a new profile, and then started the recording. However, after stopping the recording, when I Verify Test, it gives the message "401 Authorization Required".

 

How do I test windows authenticated web apps using WAPT?

 

Thanks

Share this post


Link to post
Share on other sites

"401 Authorization Required" code is a standard status code during an authentication handshake.

If the authentication was failed it was finished with "403 Forbidden code" otherwise with "200 OK".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×