Jump to content
WAPT Forum
Sign in to follow this  
Guest PLD

Does WAPT support X-Cache headers?

Recommended Posts

Guest PLD

I’m running WAPT against an application with Apache running Squid cache. The requests go in fine but Squid is not seeing them.

 

I’ve added

 

X-cache and Cache-Control to all headers and removed Pragma no-cache

 

Is there anything I else I should change?

 

Share this post


Link to post
Share on other sites
Guest angela
I’m running WAPT against an application with Apache running Squid cache. The requests go in fine but Squid is not seeing them.

 

I’ve added

 

X-cache and Cache-Control to all headers and removed Pragma no-cache

 

Is there anything I else I should change?

 

Hi,

 

WAPT does not perform caching of requests by itself, it is performed by proxy and server . In order to enable caching you need to remove the "Pragma: no-cache" string from HTTP headers.

 

To do this for all requests, just open your Profile - > Properties, click the button “Default HTTP headers...” and remove "Pragma: no-cache". It will work for all requests except subrequests - you'll need to edit their HTTP headers manually.

Share this post


Link to post
Share on other sites
Guest PLD
Hi,

 

WAPT does not perform caching of requests by itself, it is performed by proxy and server . In order to enable caching you need to remove the "Pragma: no-cache" string from HTTP headers.

 

To do this for all requests, just open your Profile - > Properties, click the button “Default HTTP headers...” and remove "Pragma: no-cache". It will work for all requests except subrequests - you'll need to edit their HTTP headers manually.

 

 

I think you misunderstand my question.

 

I've removed pragma no-cache but the request that are generated by WAPT are not being processed by the Squid cache on the application. I've tried a different load tool with the same scenarios and it works fine with the Squid cache.

 

My question is whether WAPT supports X-cache headers as removing pragma no-cache has no effect on the requests being 'seen' by the Squid cache.

 

Many thanks

 

 

Share this post


Link to post
Share on other sites
Guest PLD
Hi,

 

WAPT does not perform caching of requests by itself, it is performed by proxy and server . In order to enable caching you need to remove the "Pragma: no-cache" string from HTTP headers.

 

To do this for all requests, just open your Profile - > Properties, click the button “Default HTTP headers...” and remove "Pragma: no-cache". It will work for all requests except subrequests - you'll need to edit their HTTP headers manually.

 

 

Hi an update for you all

 

Turns out that some of the default WAPT header settings needed to be changed (Accept-Encoding gzip, deflate, accept-language en-us, remove pragma) and the user agent has to re-set away from WAPT so that the Squid cache accepts the requests

 

Is there a reason that WAPT is the default user agent?

 

Thanks!

Share this post


Link to post
Share on other sites
Guest angela
Hi an update for you all

 

Turns out that some of the default WAPT header settings needed to be changed (Accept-Encoding gzip, deflate, accept-language en-us, remove pragma) and the user agent has to re-set away from WAPT so that the Squid cache accepts the requests

 

Is there a reason that WAPT is the default user agent?

 

Thanks!

 

Hi, my apologies for the late reply... in the next version of WAPT which is going to be released in couple of months the default user agent will be IE7.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×