Jump to content
WAPT Forum
Sign in to follow this  
Guest cirej2000

IP Spoofing

Recommended Posts

Guest cirej2000

Sorry if this is in the wrong sub-forum.

 

I've been trying to get the IP Spoofing feature to work on WAPT Pro 2.0 Beta. I've gotten the IP Addresses added to my various load generator machines. However, I can't even get the load generators to their own default IP address, much less the additional IP addresses added to the TCP/IP properties in Windows XP.

 

The WAPT can see the additional IP addresses when I load them via the Load Agent manager on the WAPT Pro interface. But, that doesn't really matter since all of the 7 load generator boxes appear to be proxied via the controlling load generator's IP address.

 

Is there something additional to the set-up of IP Spoofing such as:

 

each of the load generators needs to be a full WAPT Pro instance?

further configuration outside of the Load Agent Manager Properties in WAPT Pro?

Further NW configuration in Windows?

 

Thanks,

 

 

Eric

Share this post


Link to post
Share on other sites

I've checked IP Spoofing, it works.

If you select some IPs in Load Agent Settings / IP Address List dialog, that Load Agent will use them for virtual user simulation.

 

Could you describe your problem in more details?

 

Share this post


Link to post
Share on other sites
Guest cirej2000
I've checked IP Spoofing, it works.

If you select some IPs in Load Agent Settings / IP Address List dialog, that Load Agent will use them for virtual user simulation.

 

Could you describe your problem in more details?

My problem is that sometimes I'm too stupid to follow directions correctly. ;) I enabled IP spoofing on all of the load agents (with their default addresses) and they are now having their IP addresses rotated.

 

Now I need to figure out what the deal is with the fake IP addresses.

 

 

Thanks,

 

Eric

Share this post


Link to post
Share on other sites
Guest vinod.tpf
I've checked IP Spoofing, it works.

If you select some IPs in Load Agent Settings / IP Address List dialog, that Load Agent will use them for virtual user simulation.

 

Could you describe your problem in more details?

 

 

How we can be ensure that IP spoofing is working? Is there any log maintained in reports? I am doing IP spoofing but I am not sure that WAPT is sending request from various IPs I configured. Please tell me this.

 

Thanks

 

vinod

Share this post


Link to post
Share on other sites
How we can be ensure that IP spoofing is working? Is there any log maintained in reports? I am doing IP spoofing but I am not sure that WAPT is sending request from various IPs I configured. Please tell me this.

 

Thanks

 

vinod

 

You can use netstat command. Or you can check web server logs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×